[Wien] Wien Digest, Vol 80, Issue 7

Tiem Leong Yoon tlyoon at gmail.com
Thu Aug 23 12:30:32 CEST 2012

Compilation problem of lapw0_mpi(fftw)

Dear Wien2k users,

I am tryig to compiple WIEN2k_11.1 (Release 14/6/2011) parallel version in
a Rocks Linux cluster, version 5.3. The problem I faced is very similar to
that recorded in


Specifically, I got the error while compiling parallel SRC_lapw0. This is
the only error message. The rest is OK.

fftw_para.o: In function `exec_fftw_para_':
fftw_para.F:(.text+0x77): undefined reference to `fftwnd_f77_mpi_'
fftw_para.F:(.text+0xb2): undefined reference to `fftwnd_f77_mpi_'
fftw_para.o: In function `init_fftw_para_':
fftw_para.F:(.text+0x101): undefined reference to
fftw_para.F:(.text+0x129): undefined reference to
fftw_para.F:(.text+0x14d): undefined reference to
make[1]: *** [lapw0_mpi] Error 1

The content of my Makefile is as follows:

.SUFFIXES:        .F
.SUFFIXES:        .F90
SHELL = /bin/sh
FC = ifort
MPF = /share/apps/mpich2-install/bin/mpif90
CC = cc
FOPT =  -FR -mp1 -w -prec_div -pc80 -pad -ip -DINTEL_VML -traceback
FPOPT =  -FR -mp1 -w -prec_div -pc80 -pad -ip -DINTEL_VML -traceback
-DFFTW3 /share/apps/mpich2-install/include
DParallel = '-DParallel'
LDFLAGS = -pthread -L/share/apps/intel/Compiler/11.1/072/mkl/lib/em64t
-L/share/apps/intel/Compiler/11.1/072/lib/em64t -L/share/apps/fftw3/lib
R_LIBS     = -lmkl_lapack -lmkl_intel_lp64 -lmkl_intel_thread -lmkl_core
-openmp -pthread -lguide
RP_LIBS = $(R_LIBS) -lmkl_scalapack_lp64 -lmkl_solver_lp64 -lmkl_blacs_lp64
-lfftw3 -lfftw3_mpi -lmpich -lfftw2xf_intel

I had tried very hard to get the problem solved but all in vain, even
following the suggestions as mentioned in the posts

I have tried to install various versions of fftw (fftw-2.1.5, fftw-3-3.2,
even intel version of fftw were tried), compiling them using different
compilers (mpif90 of mpich2, mpiifort), but the same problem persists, be I
use fftw or fftw2 (I also took care of -DFFTW3 and -DFFTW2 accordingly). I
can't figure out what's exactly the source of the problem. Your suggestion
will be much appreciated.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://zeus.theochem.tuwien.ac.at/pipermail/wien/attachments/20120823/44139b12/attachment.htm>

More information about the Wien mailing list