[Wien] Wien Digest, Vol 80, Issue 7

Peter Blaha pblaha at theochem.tuwien.ac.at
Thu Aug 23 15:26:11 CEST 2012

 > RP_LIBS = $(R_LIBS) -lmkl_scalapack_lp64 -lmkl_solver_lp64
 > -lmkl_blacs_lp64 -lfftw3 -lfftw3_mpi -lmpich -lfftw2xf_intel

remove -lfftw2xf_intel  from the RP_LIBS (also -lfftw3xf_intel should 
NOT be there for the parallel compilation, since -lfftw3xf_intel and 
fftw3_mpi are incompatible).

Also: when one installs fftw3 (or 2), one needs to specify some options 
to make sure that i) the mpi-version is created at all; and ii) the 
libraries are compatible with ifort-binaries (the number of appended "_" 
characters differ between eg. gfortran and ifort, ....). It is probably 
best to tell the installation that you have ifort (and preferable icc). 
I've put some notes on that in the UG (installation of fftw), but the 
exact way how to do this may vary from fftw-versions....

Am 23.08.2012 12:30, schrieb Tiem Leong Yoon:
> Compilation problem of lapw0_mpi(fftw)
> Specifically, I got the error while compiling parallel SRC_lapw0. This
> is the only error message. The rest is OK.
> fftw_para.o: In function `exec_fftw_para_':
> fftw_para.F:(.text+0x77): undefined reference to `fftwnd_f77_mpi_'
> fftw_para.F:(.text+0xb2): undefined reference to `fftwnd_f77_mpi_'

> LDFLAGS = -pthread -L/share/apps/intel/Compiler/11.1/072/mkl/lib/em64t
> -L/share/apps/intel/Compiler/11.1/072/lib/em64t -L/share/apps/fftw3/lib
> -L/share/apps/mpich2-install/lib
> R_LIBS     = -lmkl_lapack -lmkl_intel_lp64 -lmkl_intel_thread -lmkl_core
> -openmp -pthread -lguide
> RP_LIBS = $(R_LIBS) -lmkl_scalapack_lp64 -lmkl_solver_lp64
> -lmkl_blacs_lp64 -lfftw3 -lfftw3_mpi -lmpich -lfftw2xf_intel
> =========================
> I had tried very hard to get the problem solved but all in vain, even
> following the suggestions as mentioned in the posts
> http://zeus.theochem.tuwien.ac.at/pipermail/wien/2011-December/015856.html,
> http://zeus.theochem.tuwien.ac.at/pipermail/wien/2010-October/013900.html
> I have tried to install various versions of fftw (fftw-2.1.5,
> fftw-3-3.2, even intel version of fftw were tried), compiling them using
> different compilers (mpif90 of mpich2, mpiifort), but the same problem
> persists, be I use fftw or fftw2 (I also took care of -DFFTW3 and
> -DFFTW2 accordingly). I can't figure out what's exactly the source of
> the problem. Your suggestion will be much appreciated.
> tl
> _______________________________________________
> Wien mailing list
> Wien at zeus.theochem.tuwien.ac.at
> http://zeus.theochem.tuwien.ac.at/mailman/listinfo/wien

Peter Blaha
Inst.Materials Chemistry
TU Vienna
Getreidemarkt 9
A-1060 Vienna

More information about the Wien mailing list