[Wien] Telnes3 compilation

Peter Blaha pblaha at theochem.tuwien.ac.at
Wed Mar 14 10:06:14 CET 2012

Please check previous posting on TELNES3. It was discussed and solved before.

gfortran supports only lines with some limited length. This leads to those errors.
You have to break these lines into two with a continuation character.

The new release should have fixed this.

Am 13.03.2012 10:07, schrieb aeljarrat at el.ub.edu:
> Dear WIEN2k Users and Developers,
> it appears to be some problem I have not been able to sort out in the
> compilation of the TELNES3 program in my system (Ubuntu 11.04 Natty). I
> have been testing the rest of my Wien2k compilation, and it seems to be
> working fine as I tested it through all the examples.
> Maybe somebody has solved this problem, or at least gets it too, and maybe
> can give me some insight about it.
> This is what it looks like:
>> /opt/WIEN/SRC_telnes3/compile.msg:Error: Unterminated character constant
> beginning at (1)
>> /opt/WIEN/SRC_telnes3/compile.msg-describetask.f:69.114:
>> /opt/WIEN/SRC_telnes3/compile.msg-
>> /opt/WIEN/SRC_telnes3/compile.msg-a)') 'logarithmic mesh of ',nr*nr*nt,'
> points with nr = ',nr,' , nt = ',nt,' ,s
>> /opt/WIEN/SRC_telnes3/compile.msg-
>                                      1
>> /opt/WIEN/SRC_telnes3/compile.msg:Error: Unterminated character constant
> beginning at (1)
>> /opt/WIEN/SRC_telnes3/compile.msg-describetask.f:70.5:
>> /opt/WIEN/SRC_telnes3/compile.msg-
>> /opt/WIEN/SRC_telnes3/compile.msg-     Th0*dble(1000),' mrad.'
>> /opt/WIEN/SRC_telnes3/compile.msg-     1
>> /opt/WIEN/SRC_telnes3/compile.msg:Error: Unclassifiable statement at (1)
>> /opt/WIEN/SRC_telnes3/compile.msg:make: *** [describetask.o] Error 1
>> /opt/WIEN/SRC_telnes3/compile.msg-make: *** No rule to make target
> `complex'.  Stop.
> (So far, these are all the errors appearing after full compilation)
> I get the following error when trying to create the case.qt1 file with "x
> qtl -telnes".
>> At line 459 of file qtlmain.f (unit = 60, file = 'AlN.energy')
>> Fortran runtime error: End of file
>> 0.0u 0.0s 0:00.00 0.0% 0+0k 0+40io 0pf+0w
>> error: command   /opt/WIEN/qtl qtl.def   failed
> For the compilation I'm using  gfortran and gotolib (I plan on updating to
> ifort, but first I'd like to fix this problem) and a very simple AlN.innes
> file (attached to this mail together with the compiler OPTIONS file). So
> far, I've been browsing the archives, but found nothing about this
> problem. Also, I have to inform that I'm not very proficient in FORTRAN,
> so I'm sorry if this compilation error turns out to be just very simple to
> fix...
> Can somebody help me here?
> Thanks a lot!
> Alberto Eljarrat
> predoc student
> Univ. of Barcelona
> _______________________________________________
> Wien mailing list
> Wien at zeus.theochem.tuwien.ac.at
> http://zeus.theochem.tuwien.ac.at/mailman/listinfo/wien


Peter BLAHA, Inst.f. Materials Chemistry, TU Vienna, A-1060 Vienna
Phone: +43-1-58801-165300             FAX: +43-1-58801-165982
Email: blaha at theochem.tuwien.ac.at    WWW: http://info.tuwien.ac.at/theochem/

More information about the Wien mailing list